Atlassian Jira/Crowd Troubleshooting

So Recently I had an issue with Atlassian Jira in which pages listing issues were not updating, but the issues themselves were.

Simple Resolution I thought as I removed backups from the previous year and freed up some disk space. I stopped Jira, with a

/etc/init.d/tomcat5.5 stop

Then removed the old backups and started jira again.

But that is when another problem arose – no one could log in! oh shite… how the hell do I fix this?!

It turns out that when you stop tomcat (and therefore Crowd)  Crowd writes out a config file, but since the disk was full, it could not write the file to disk!!! So, here is the file in question

ll ./atlassian/crowd/home/crowd.cfg.xml
-rw-r--r-- 1 tomcat55 nogroup 0 2011-06-15 10:42 ./atlassian/crowd/home/crowd.cfg.xml

See that 0 – that’s bad mkay. Luckily we have system backups and I skitched the file from there, stopped tomcat put the file in place and started it again.

we can now login – WOO fricken HOO… except where the heck are all of our issues?!

Here we go again. TM

The issues themselves are there but somehow the issues are no longer associated with their users.

This was easily enough resolved, I stopped tomcat, moved the old “jira.home” directory out of the way, created a new empty directory (assigning it the correct user permissions) and then restarted tomcat. This forced Jira to recreate a lot of things. After a few users browsed around in Jira for a bit the indexes were created again and all was good.

Side Note: The Opera web browser likes to cache things. If you are getting blank pages for your “Assigned to me” gadget, delete your cookies for your Jira installation, close your browser and start it again.